New beta games require 2.0 firmware

Digg This
Del.icio.us

There is couple of new games went to beta testing and require you to install 2.0 version firmware even to apply for the beta testing (they want you to use the browser coming with 2.0). Of course, if you do that, you can forget about homebrew software, as there is currently none working above 1.5.

Posted 8/30/2005 3:00:00 AM @ 13:22:00 | Sony PSP




Comments are locked for this entry.

categories

archive »


recent comments


Click here to see the recent comments from the old comments system
search


statistics

This blog currently has 346 entries and 2327 comments in 9 categories.

There are 26 active users.