Now you can run games which require 2.71 firmware

Digg This
Del.icio.us

The Devhook 0.44 for Sony PSP has been released. It allows you to play games from your memory stick on your 1.5 firmware and supports games requiring up to 2.71 firmware.

After the release of v2.50 and v2.60 downgraders, this is some great news. Grab the latest Devhook from here. The page has full set of instructions as well.

Posted 7/14/2006 3:00:00 AM @ 13:21:00 | Sony PSP




Comments are locked for this entry.

categories

archive »


recent comments


Click here to see the recent comments from the old comments system
search


statistics

This blog currently has 346 entries and 2327 comments in 9 categories.

There are 27 active users.